$re = '/(?:\"language_display\":\[(?:"1")\])/';
$str = '{"language_display":["1","2","3"],"quantity":1500,"meta_display:":["1","2","3"]}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);