// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:\"language_display\":\[(?:"1")\])"#).unwrap();
let string = "{\"language_display\":[\"1\",\"2\",\"3\"],\"quantity\":1500,\"meta_display:\":[\"1\",\"2\",\"3\"]}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}