package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\"language_display\":\[(?:"1")\])`)
var str = `{"language_display":["1","2","3"],"quantity":1500,"meta_display:":["1","2","3"]}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}