re = /(?:\"language_display\":\[(?:"1")\])/
str = '{"language_display":["1","2","3"],"quantity":1500,"meta_display:":["1","2","3"]}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end