import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^፻.+)\\b(\\w+)(?=.*፻$)፻?";
final String string = "፻this test works፻\n"
+ "፻this test does not work፻\n"
+ "this is a line that stays unchanged\n"
+ "this is a line that stays unchanged፻\n"
+ "፻this is a line that stays unchanged";
final String subst = "፻$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}