import re
regex = re.compile(r"(?<=^፻.+)\b(\w+)(?=.*፻$)፻?", flags=re.MULTILINE)
test_str = ("፻this test works፻\n"
"፻this test does not work፻\n"
"this is a line that stays unchanged\n"
"this is a line that stays unchanged፻\n"
"፻this is a line that stays unchanged")
subst = "፻$1"
result = regex.sub(subst, test_str)
if result:
print(result)