const regex = new RegExp('(?<=^፻.+)\\b(\\w+)(?=.*፻$)፻?', 'gm')
const str = `፻this test works፻
፻this test does not work፻
this is a line that stays unchanged
this is a line that stays unchanged፻
፻this is a line that stays unchanged`;
const subst = `፻$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);