using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]\d+:[A-Z]\d+,\d+(?: [A-Z]\d+:[A-Z]\d+,\d+)+$";
string input = @"B3:D7,0 H3:J7,0 B9:L27,1 B29:L48,2 B50:L56,2
B3:D7,0 H3:J7,0 B9:L27,1 B29:L48,2 B50:L56,2
B3:D7,0 H3:J7,0 B9:L27,1 B29:L48,2 B50:L56,2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}