const regex = /^[A-Z]\d+:[A-Z]\d+,\d+(?: [A-Z]\d+:[A-Z]\d+,\d+)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z]\\d+:[A-Z]\\d+,\\d+(?: [A-Z]\\d+:[A-Z]\\d+,\\d+)+$', 'gm')
const str = `B3:D7,0 H3:J7,0 B9:L27,1 B29:L48,2 B50:L56,2
B3:D7,0 H3:J7,0 B9:L27,1 B29:L48,2 B50:L56,2
B3:D7,0 H3:J7,0 B9:L27,1 B29:L48,2 B50:L56,2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}