import Foundation
let pattern = #"^[A-Z]\d+:[A-Z]\d+,\d+(?: [A-Z]\d+:[A-Z]\d+,\d+)+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
B3:D7,0 H3:J7,0 B9:L27,1 B29:L48,2 B50:L56,2
B3:D7,0 H3:J7,0 B9:L27,1 B29:L48,2 B50:L56,2
B3:D7,0 H3:J7,0 B9:L27,1 B29:L48,2 B50:L56,2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)