use strict;
my $str = 'B3:D7,0 H3:J7,0 B9:L27,1 B29:L48,2 B50:L56,2
B3:D7,0 H3:J7,0 B9:L27,1 B29:L48,2 B50:L56,2
B3:D7,0 H3:J7,0 B9:L27,1 B29:L48,2 B50:L56,2';
my $regex = qr/^[A-Z]\d+:[A-Z]\d+,\d+(?: [A-Z]\d+:[A-Z]\d+,\d+)+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}