$re = '/^[A-Z]\d+:[A-Z]\d+,\d+(?: [A-Z]\d+:[A-Z]\d+,\d+)+$/m';
$str = 'B3:D7,0 H3:J7,0 B9:L27,1 B29:L48,2 B50:L56,2
B3:D7,0 H3:J7,0 B9:L27,1 B29:L48,2 B50:L56,2
B3:D7,0 H3:J7,0 B9:L27,1 B29:L48,2 B50:L56,2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);