package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<div class="img__box _ga1_on_ _ga3_on_ _ga1_on _ga3_on">(.*?)\<\/div\>`)
var str = `<div class="sub__caption__section clearfloat">
<div class="img__box _ga1_on_ _ga3_on_ _ga1_on _ga3_on">
<a href="/media/images/original/original15986477.jpg" class="colorbox group1"><img src="/media/images/uploaded/inner15986477.jpg" alt="Опубликован список пятиэтажек, которые могут пойти под снос" title="Опубликован список пятиэтажек, которые могут пойти под снос"></a>
</div>
<p>Голосование будет проходить с 15 мая по 15 июня в электронной системе «Активный гражданин», а также центрах государственных услуг «Мои документы». <span class="big__bullet"></span></p>
<div class="strips h__7"></div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}