import Foundation
let pattern = #"<div class="img__box _ga1_on_ _ga3_on_ _ga1_on _ga3_on">(.*?)\<\/div\>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<div class="sub__caption__section clearfloat">
<div class="img__box _ga1_on_ _ga3_on_ _ga1_on _ga3_on">
<a href="/media/images/original/original15986477.jpg" class="colorbox group1"><img src="/media/images/uploaded/inner15986477.jpg" alt="Опубликован список пятиэтажек, которые могут пойти под снос" title="Опубликован список пятиэтажек, которые могут пойти под снос"></a>
</div>
<p>Голосование будет проходить с 15 мая по 15 июня в электронной системе «Активный гражданин», а также центрах государственных услуг «Мои документы». <span class="big__bullet"></span></p>
<div class="strips h__7"></div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)