use strict;
my $str = '<div class="sub__caption__section clearfloat">
<div class="img__box _ga1_on_ _ga3_on_ _ga1_on _ga3_on">
<a href="/media/images/original/original15986477.jpg" class="colorbox group1"><img src="/media/images/uploaded/inner15986477.jpg" alt="Опубликован список пятиэтажек, которые могут пойти под снос" title="Опубликован список пятиэтажек, которые могут пойти под снос"></a>
</div>
<p>Голосование будет проходить с 15 мая по 15 июня в электронной системе «Активный гражданин», а также центрах государственных услуг «Мои документы». <span class="big__bullet"></span></p>
<div class="strips h__7"></div>';
my $regex = qr/<div class="img__box _ga1_on_ _ga3_on_ _ga1_on _ga3_on">(.*?)\<\/div\>/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}