// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)<div class="img__box _ga1_on_ _ga3_on_ _ga1_on _ga3_on">(.*?)\<\/div\>"#).unwrap();
let string = "<div class=\"sub__caption__section clearfloat\">
<div class=\"img__box _ga1_on_ _ga3_on_ _ga1_on _ga3_on\">
<a href=\"/media/images/original/original15986477.jpg\" class=\"colorbox group1\"><img src=\"/media/images/uploaded/inner15986477.jpg\" alt=\"Опубликован список пятиэтажек, которые могут пойти под снос\" title=\"Опубликован список пятиэтажек, которые могут пойти под снос\"></a>
</div>
<p>Голосование будет проходить с 15 мая по 15 июня в электронной системе «Активный гражданин», а также центрах государственных услуг «Мои документы». <span class=\"big__bullet\"></span></p>
<div class=\"strips h__7\"></div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}