const regex = /<div class="img__box _ga1_on_ _ga3_on_ _ga1_on _ga3_on">(.*?)\<\/div\>/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div class="img__box _ga1_on_ _ga3_on_ _ga1_on _ga3_on">(.*?)\\<\\\/div\\>', 'gs')
const str = `<div class="sub__caption__section clearfloat">
<div class="img__box _ga1_on_ _ga3_on_ _ga1_on _ga3_on">
<a href="/media/images/original/original15986477.jpg" class="colorbox group1"><img src="/media/images/uploaded/inner15986477.jpg" alt="Опубликован список пятиэтажек, которые могут пойти под снос" title="Опубликован список пятиэтажек, которые могут пойти под снос"></a>
</div>
<p>Голосование будет проходить с 15 мая по 15 июня в электронной системе «Активный гражданин», а также центрах государственных услуг «Мои документы». <span class="big__bullet"></span></p>
<div class="strips h__7"></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}