import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)PLC\\.com(?:\\/\\ben\\b)?(.*)";
final String string = "https://www.mycompanyPLC.com/en/lorem/ipsum/whatever\n"
+ "https://www.mycompanyPLC.com/lorem/ipsum/whatever\n"
+ "http://www.mycompanyPLC.com/random/query/url\n"
+ "http://www.mycompanyPLC.com/en/random/query/url\n"
+ "ftp://www.mycompanyPLC.com/en/random/query/url\n\n";
final String subst = "$1LTD.com$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}