$re = '/(.*?)PLC\.com(?:\/\ben\b)?(.*)/m';
$str = 'https://www.mycompanyPLC.com/en/lorem/ipsum/whatever
https://www.mycompanyPLC.com/lorem/ipsum/whatever
http://www.mycompanyPLC.com/random/query/url
http://www.mycompanyPLC.com/en/random/query/url
ftp://www.mycompanyPLC.com/en/random/query/url
';
$subst = "$1LTD.com$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;