const regex = /(.*?)PLC\.com(?:\/\ben\b)?(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)PLC\\.com(?:\\\/\\ben\\b)?(.*)', 'gm')
const str = `https://www.mycompanyPLC.com/en/lorem/ipsum/whatever
https://www.mycompanyPLC.com/lorem/ipsum/whatever
http://www.mycompanyPLC.com/random/query/url
http://www.mycompanyPLC.com/en/random/query/url
ftp://www.mycompanyPLC.com/en/random/query/url
`;
const subst = `$1LTD.com$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);