#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[A-Z])(?=.*[a-z])(?=.*\d)(?=.*[?!@])[A-Za-z\d@!?]{8,}$"
Local $sString = "sgnbkb" & @CRLF & _
"sdfAijisrg8990&^" & @CRLF & _
"dfvhgjRFDG68^&*^" & @CRLF & _
"" & @CRLF & _
"ALDHJH777@" & @CRLF & _
"ALDHJH777@s" & @CRLF & _
"%^^&^&" & @CRLF & _
"&*^&7897" & @CRLF & _
"" & @CRLF & _
"Pa!!w0rd" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")