using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[A-Z])(?=.*[a-z])(?=.*\d)(?=.*[?!@])[A-Za-z\d@!?]{8,}$";
string input = @"sgnbkb
sdfAijisrg8990&^
dfvhgjRFDG68^&*^
ALDHJH777@
ALDHJH777@s
%^^&^&
&*^&7897
Pa!!w0rd
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}