import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[A-Z])(?=.*[a-z])(?=.*\\d)(?=.*[?!@])[A-Za-z\\d@!?]{8,}$";
final String string = "sgnbkb\n"
+ "sdfAijisrg8990&^\n"
+ "dfvhgjRFDG68^&*^\n\n"
+ "ALDHJH777@\n"
+ "ALDHJH777@s\n"
+ "%^^&^&\n"
+ "&*^&7897\n\n"
+ "Pa!!w0rd\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}