$re = '/^(?=.*[A-Z])(?=.*[a-z])(?=.*\d)(?=.*[?!@])[A-Za-z\d@!?]{8,}$/m';
$str = 'sgnbkb
sdfAijisrg8990&^
dfvhgjRFDG68^&*^
ALDHJH777@
ALDHJH777@s
%^^&^&
&*^&7897
Pa!!w0rd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);