import re
regex = re.compile(r"^(?=.*[A-Z])(?=.*[a-z])(?=.*\d)(?=.*[?!@])[A-Za-z\d@!?]{8,}$", flags=re.MULTILINE)
test_str = ("sgnbkb\n"
"sdfAijisrg8990&^\n"
"dfvhgjRFDG68^&*^\n\n"
"ALDHJH777@\n"
"ALDHJH777@s\n"
"%^^&^&\n"
"&*^&7897\n\n"
"Pa!!w0rd\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")