#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=;charge=)([^-]+?)(?=&lang=en&pt=0&w=)"
Local $sString = "https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=" & @CRLF & _
"https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=" & @CRLF & _
"https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=" & @CRLF & _
"https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=" & @CRLF & _
"https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=" & @CRLF & _
"https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")