const regex = /(?<=;charge=)([^-]+?)(?=&lang=en&pt=0&w=)/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=;charge=)([^-]+?)(?=&lang=en&pt=0&w=)', 'm')
const str = `https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}