using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=;charge=)([^-]+?)(?=&lang=en&pt=0&w=)";
string input = @"https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}