package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.+?)\s*\(([A-Z]?\d+)\)(.*)$`)
var str = `Ann Smith (A123456)
Tom Ford (2453234)
Alex Mohammet (4447434) (text)
Gerad Kowalski (A6739263)`
var substitution = "$1$3|$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}