use strict;
my $str = 'Ann Smith (A123456)
Tom Ford (2453234)
Alex Mohammet (4447434) (text)
Gerad Kowalski (A6739263)';
my $regex = qr`^(.+?)\s*\(([A-Z]?\d+)\)(.*)$`mp;
my $subst = '$1$3|$2';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";