const regex = new RegExp('^(.+?)\\s*\\(([A-Z]?\\d+)\\)(.*)$', 'gm')
const str = `Ann Smith (A123456)
Tom Ford (2453234)
Alex Mohammet (4447434) (text)
Gerad Kowalski (A6739263)`;
const subst = `$1$3|$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);