import Foundation
let pattern = #"^(.+?)\s*\(([A-Z]?\d+)\)(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Ann Smith (A123456)
Tom Ford (2453234)
Alex Mohammet (4447434) (text)
Gerad Kowalski (A6739263)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$3|$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)