re = /^(.+?)\s*\(([A-Z]?\d+)\)(.*)$/m
str = 'Ann Smith (A123456)
Tom Ford (2453234)
Alex Mohammet (4447434) (text)
Gerad Kowalski (A6739263)'
subst = '$1$3|$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result