#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^0?(?:[1-9]|1[0-2])\/0?(?:[1-9]|12[0-9]|3[01])\/1\d{3}"
Local $sString = "12/10/2021" & @CRLF & _
"1/1/1990" & @CRLF & _
"01/08/1937" & @CRLF & _
"15/36/1718" & @CRLF & _
"3/33/1999" & @CRLF & _
"1/2/2000" & @CRLF & _
"12/9/1906" & @CRLF & _
"13/31/1999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")