use strict;
my $str = '12/10/2021
1/1/1990
01/08/1937
15/36/1718
3/33/1999
1/2/2000
12/9/1906
13/31/1999';
my $regex = qr/^0?(?:[1-9]|1[0-2])\/0?(?:[1-9]|12[0-9]|3[01])\/1\d{3}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}