import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^0?(?:[1-9]|1[0-2])\\/0?(?:[1-9]|12[0-9]|3[01])\\/1\\d{3}";
final String string = "12/10/2021\n"
+ "1/1/1990\n"
+ "01/08/1937\n"
+ "15/36/1718\n"
+ "3/33/1999\n"
+ "1/2/2000\n"
+ "12/9/1906\n"
+ "13/31/1999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}