using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^0?(?:[1-9]|1[0-2])\/0?(?:[1-9]|12[0-9]|3[01])\/1\d{3}";
string input = @"12/10/2021
1/1/1990
01/08/1937
15/36/1718
3/33/1999
1/2/2000
12/9/1906
13/31/1999";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}