import re
regex = re.compile(r"^0?(?:[1-9]|1[0-2])\/0?(?:[1-9]|12[0-9]|3[01])\/1\d{3}", flags=re.MULTILINE)
test_str = ("12/10/2021\n"
"1/1/1990\n"
"01/08/1937\n"
"15/36/1718\n"
"3/33/1999\n"
"1/2/2000\n"
"12/9/1906\n"
"13/31/1999")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")