package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z](?:[1-9]|1[0-2])$`)
var str = `A1
A2
B3
C4
A23
A12
B22
Z3
Z13
Q11
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}