import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z](?:[1-9]|1[0-2])$";
final String string = "A1\n"
+ "A2\n"
+ "B3\n"
+ "C4\n"
+ "A23\n"
+ "A12\n"
+ "B22\n"
+ "Z3\n"
+ "Z13\n"
+ "Q11\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}