import re
regex = re.compile(r"^[A-Z](?:[1-9]|1[0-2])$", flags=re.MULTILINE)
test_str = ("A1\n"
"A2\n"
"B3\n"
"C4\n"
"A23\n"
"A12\n"
"B22\n"
"Z3\n"
"Z13\n"
"Q11\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")