const regex = /^[A-Z](?:[1-9]|1[0-2])$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z](?:[1-9]|1[0-2])$', 'mg')
const str = `A1
A2
B3
C4
A23
A12
B22
Z3
Z13
Q11
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}