using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"''Long?(?:'')?\.(?:'')? .*?(?P<Degrees>\d+).*?d.+?(?P<Minutes>\d+)′.*?(?P<Seconds>\d+)″.*?(?:'')?lat(?:'')?\.(?:'')?.*?(?P<Degrees>\d+).*?d.+?(?P<Minutes>\d+)′.*?(?P<Seconds>\d+)″.*?";
string input = @"''These are the coordinates'' :
''Long. 17d. 6′. 8″. lat. 47d. 28′. 8″
''Lon. ''36d. 70′. 80″. ''lat. 45d. 20′. 5″
''Long. 17d. 6′. 8″.
lat. 47d. 28′. 8″";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}