// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)''Long?(?:'')?\.(?:'')? .*?(?P<Degrees>\d+).*?d.+?(?P<Minutes>\d+)′.*?(?P<Seconds>\d+)″.*?(?:'')?lat(?:'')?\.(?:'')?.*?(?P<Degrees>\d+).*?d.+?(?P<Minutes>\d+)′.*?(?P<Seconds>\d+)″.*?").unwrap();
let string = "''These are the coordinates'' :
''Long. 17d. 6′. 8″. lat. 47d. 28′. 8″
''Lon. ''36d. 70′. 80″. ''lat. 45d. 20′. 5″
''Long. 17d. 6′. 8″.
lat. 47d. 28′. 8″";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}