# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"''Long?(?:'')?\.(?:'')? .*?(?P<Degrees>\d+).*?d.+?(?P<Minutes>\d+)′.*?(?P<Seconds>\d+)″.*?(?:'')?lat(?:'')?\.(?:'')?.*?(?P<Degrees>\d+).*?d.+?(?P<Minutes>\d+)′.*?(?P<Seconds>\d+)″.*?"
test_str = ("''These are the coordinates'' : \n"
"''Long. 17d. 6′. 8″. lat. 47d. 28′. 8″\n"
"''Lon. ''36d. 70′. 80″. ''lat. 45d. 20′. 5″\n"
"''Long. 17d. 6′. 8″.\n"
"lat. 47d. 28′. 8″")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.