import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "''Long?(?:'')?\\.(?:'')? .*?(?P<Degrees>\\d+).*?d.+?(?P<Minutes>\\d+)′.*?(?P<Seconds>\\d+)″.*?(?:'')?lat(?:'')?\\.(?:'')?.*?(?P<Degrees>\\d+).*?d.+?(?P<Minutes>\\d+)′.*?(?P<Seconds>\\d+)″.*?";
final String string = "''These are the coordinates'' : \n"
+ "''Long. 17d. 6′. 8″. lat. 47d. 28′. 8″\n"
+ "''Lon. ''36d. 70′. 80″. ''lat. 45d. 20′. 5″\n"
+ "''Long. 17d. 6′. 8″.\n"
+ "lat. 47d. 28′. 8″";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}