using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^/]+\.[^.]+$";
string input = @"http://www.demo.com/profiles-forum/linda-blair.php
http://www.demo.com/profiles-forum/linda-blair.txt
http://www.demo.com/profiles-forum/linda-blair.jpeg
http://www.demo.com/profiles-forum/linda_blair.php
http://www.demo.com/profiles-forum/linda.blair.txt
http://www.demo.com/profiles-forum/lindablair.jpeg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}