$re = '~[^/]+\.[^.]+$~m';
$str = 'http://www.demo.com/profiles-forum/linda-blair.php
http://www.demo.com/profiles-forum/linda-blair.txt
http://www.demo.com/profiles-forum/linda-blair.jpeg
http://www.demo.com/profiles-forum/linda_blair.php
http://www.demo.com/profiles-forum/linda.blair.txt
http://www.demo.com/profiles-forum/lindablair.jpeg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);