re = /[^\/]+\.[^.]+$/m
str = 'http://www.demo.com/profiles-forum/linda-blair.php
http://www.demo.com/profiles-forum/linda-blair.txt
http://www.demo.com/profiles-forum/linda-blair.jpeg
http://www.demo.com/profiles-forum/linda_blair.php
http://www.demo.com/profiles-forum/linda.blair.txt
http://www.demo.com/profiles-forum/lindablair.jpeg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end