package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^/]+\.[^.]+$`)
var str = `http://www.demo.com/profiles-forum/linda-blair.php
http://www.demo.com/profiles-forum/linda-blair.txt
http://www.demo.com/profiles-forum/linda-blair.jpeg
http://www.demo.com/profiles-forum/linda_blair.php
http://www.demo.com/profiles-forum/linda.blair.txt
http://www.demo.com/profiles-forum/lindablair.jpeg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}